Why You Want It

SoftBlock™ is a software-based forensic write-blocking tool. SoftBlock quickly identifies newly attached hardware devices, and mounts the device with read-only or read-write permissions according to user preference. This forensic software is built to handle the needs of both large-scale digital forensic labs and individual forensic practitioners.

Are you intersted in this product?

1300 55 33 24

contact@cdfs.com.au

Quote Request

SoftBlock

SoftBlock™ is a software-based forensic write-blocking tool. SoftBlock quickly identifies newly attached hardware devices, and mounts the device with read-only or read-write permissions according to user preference. This forensic software is built to handle the needs of both large-scale digital forensic labs and individual forensic practitioners. SoftBlock allows forensic examiners to quickly and safely preview data contained on evidentiary devices before data is imported. SoftBlock is built to run on a forensic examiner’s analysis machine; no additional expensive or cumbersome hardware is needed.

Note: The current version of SoftBlock (1.1.0) is compatible with OS X 10.9.5 – 10.13.3. SoftBlock 1.0.7 is compatible with OS X 10.7.x – 10.10.x. If you are running a version of OS X that is older than 10.7, you will need SoftBlock 1.0.5.

SUPPORT FOR MAC OS X

SoftBlock runs on OS X 10.9.5 – 10.13.3.

SCALABILITY

SoftBlock handles as many hardware devices as a forensic analysis machine allows.

MOBILITY

Avoid purchasing expensive write-blocking hardware. SoftBlock blocks data transfer at the kernel-level.

DEVICE MANAGEMENT

A true time-saver. Quickly and safely mount and preview multiple external devices.

SEAMLESS WORKFLOW INTEGRATION

SoftBlock features an intuitive user interface. Once installed, SoftBlock runs in the background and is available for use on demand.

 

System Requirements:

OPERATING SYSTEM SPECIFICATION Mac OS X
COMPATIBILITY Ver 1.1.0 Supports Mavericks (from 10.9.5), Yosemite (10.10.x), El Capitan (through 10.11.5), and Sierra (through 10.12.0)
Ver 1.0.7 Supports Lion (10.7.x), Mountain Lion (10.8.x), Mavericks (10.9.x), and Yosemite (10.10.x)
Ver 1.0.5 Supports Snow Leopard (10.6.x), Lion (10.7.x), and Mountain Lion (10.8.x)
Ver 1.0.4 Supports Leopard (10.5.X) and Snow Leopard (10.6.X)
MINIMUM REQUIREMENTS 2GB RAM
25 MB Install space
OPTIMUM REQUIREMENTS No

 

/* Omit closing PHP tag at the end of PHP files to avoid "headers already sent" issues. */